<!DOCTYPE html>
<html class="client-nojs vector-feature-language-in-header-enabled vector-feature-language-in-main-menu-disabled vector-feature-language-in-main-page-header-disabled vector-feature-page-tools-pinned-disabled vector-feature-toc-pinned-clientpref-0 vector-toc-not-available vector-feature-main-menu-pinned-disabled vector-feature-limited-width-clientpref-1 vector-feature-limited-width-content-enabled vector-feature-custom-font-size-clientpref-1 vector-feature-appearance-pinned-clientpref-0 skin-theme-clientpref-os vector-sticky-header-enabled skin-theme-clientpref-thumb-standard" lang="pt" dir="ltr"><head>
    <meta charset="UTF-8">
    <title>MIME</title>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="icon" type="image/png" href="./_res_/favicon.png">
    <link rel="canonical" href="https://pt.wikipedia.org/wiki/MIME"> <link href="./_mw_/ext.wikimediamessages.styles.css" rel="stylesheet" type="text/css">
    <link href="./_mw_/mediawiki.skinning.content.parsoid.css" rel="stylesheet" type="text/css">
    <link href="./_mw_/skins.vector.icons.css" rel="stylesheet" type="text/css">
    <link href="./_mw_/skins.vector.search.codex.styles.css" rel="stylesheet" type="text/css">
    <link href="./_mw_/skins.vector.styles.css" rel="stylesheet" type="text/css">
    <meta name="ResourceLoaderDynamicStyles" content="">
    <link href="./_mw_/ext.gadget.keepPDU.css" rel="stylesheet" type="text/css">
    <link rel="stylesheet" type="text/css" href="./_mw_/site.styles.css">
    <link rel="stylesheet" type="text/css" href="./_mw_/noscript.css">
    <link rel="stylesheet" type="text/css" href="./_res_/footer.css">
    <link rel="stylesheet" type="text/css" href="./_res_/vector-2022.css">
  </head>
  <body class="skin--responsive skin-vector skin-vector-search-vue mediawiki ltr sitedir-ltr mw-hide-empty-elt ns-0 ns-subject page-MIME rootpage-MIME skin-vector-2022 action-view">
    <div class="mw-page-container">
      <div class="mw-page-container-inner">
        <div class="mw-content-container">
          <main id="content" class="mw-body">
            <header class="mw-body-header vector-page-titlebar">
              <h1 id="firstHeading" class="firstHeading mw-first-heading"><span lang="pt" dir="ltr"><span class="mw-page-title-main">MIME</span></span></h1>
            </header>
            <a id="top"></a>
            <div id="bodyContent" class="vector-body ve-init-mw-desktopArticleTarget-targetContainer" aria-labelledby="firstHeading" data-mw-ve-target-container="">
              <div id="contentSub">
                <div id="mw-content-subtitle"></div>
              </div>
              <div id="mw-content-text" class="mw-body-content mw-content-ltr" lang="pt" dir="ltr"><div class="mw-content-ltr mw-parser-output" lang="pt" dir="ltr" data-mw-parsoid-version="0.23.0.0-alpha27" data-mw-html-version="2.8.0"><section data-mw-section-id="0" id="mwAQ"><div class="hatnote" typeof="mw:Transclusion" id="mwAg"><span typeof="mw:File"><span><img src="./_assets_/0c70a452f799bfe840676ee341124611/Disambig_grey.svg.png" decoding="async" data-file-width="260" data-file-height="200" data-file-type="drawing" height="15" width="20" class="mw-file-element" loading="lazy"></span></span><span typeof="mw:Entity">&nbsp;</span><b>Nota:</b> Se procura por outras acepções, veja <a rel="mw:WikiLink" href="Mime" title="Mime" class="mw-disambig">Mime</a>.</div>
<style data-mw-deduplicate="TemplateStyles:r71224021" typeof="mw:Extension/templatestyles mw:Transclusion" id="mwAw">
/* start https://pt.wikipedia.org/ */


.mw-parser-output .ambox{border:1px solid #a2a9b1;border-left:10px solid #36c;background-color:#fbfbfb;box-sizing:border-box}.mw-parser-output .ambox+link+.ambox,.mw-parser-output .ambox+link+style+.ambox,.mw-parser-output .ambox+link+link+.ambox,.mw-parser-output .ambox+.mw-empty-elt+link+.ambox,.mw-parser-output .ambox+.mw-empty-elt+link+style+.ambox,.mw-parser-output .ambox+.mw-empty-elt+link+link+.ambox{margin-top:-1px}html body.mediawiki .mw-parser-output .ambox.mbox-small-left{margin:4px 1em 4px 0;overflow:hidden;width:238px;border-collapse:collapse;font-size:88%;line-height:1.25em}.mw-parser-output .ambox-speedy{border-left:10px solid #b32424;background-color:#fee7e6}.mw-parser-output .ambox-delete{border-left:10px solid #b32424}.mw-parser-output .ambox-content{border-left:10px solid #f28500}.mw-parser-output .ambox-style{border-left:10px solid #fc3}.mw-parser-output .ambox-move{border-left:10px solid #9932cc}.mw-parser-output .ambox-protection{border-left:10px solid #a2a9b1}.mw-parser-output .ambox .mbox-text{border:none;padding:0.25em 0.5em;width:100%}.mw-parser-output .ambox .mbox-image{border:none;padding:2px 0 2px 0.5em;text-align:center}.mw-parser-output .ambox .mbox-imageright{border:none;padding:2px 0.5em 2px 0;text-align:center}.mw-parser-output .ambox .mbox-empty-cell{border:none;padding:0;width:1px}.mw-parser-output .ambox .mbox-image-div{width:52px}@media(min-width:720px){.mw-parser-output .ambox{margin:0 10%}}@media print{body.ns-0 .mw-parser-output .ambox{display:none!important}}


/* end   https://pt.wikipedia.org/ */
</style>
<p id="mwBQ"><b id="mwBg">Extensões Multi função para Mensagens de Internet</b> (sigla <b id="mwBw">MIME</b> do inglês <i id="mwCA">Multipurpose Internet Mail Extensions</i>) é uma norma da internet para o formato das mensagens de <a rel="mw:WikiLink" href="Correio_eletr%C3%B4nico" title="Correio eletrônico" class="mw-redirect" id="mwCQ">correio eletrônico</a>. A grande maioria das mensagens de correio eletrônico são trocadas usando o protocolo <a rel="mw:WikiLink" href="SMTP" title="SMTP" class="mw-redirect" id="mwCg">SMTP</a> e usam o formato MIME. As mensagens na Internet tem uma associação tão estreita aos padrões SMTP e MIME que algumas vezes são chamadas de mensagens <b id="mwCw">SMTP/MIME</b>.</p>

<p id="mwDA">O protocolo básico de transmissão de e-mail pela Internet, SMTP, suporta apenas 7-bit de caracteres <a rel="mw:WikiLink" href="ASCII" title="ASCII" id="mwDQ">ASCII</a>. Isto limita as mensagens de emails, incluindo somente os caracteres usados na <a rel="mw:WikiLink" href="L%C3%ADngua_inglesa" title="Língua inglesa" id="mwDg">língua inglesa</a>.</p>

<p id="mwDw">O MIME provê mecanismos para o envio de outros tipos de informações por e-mail, incluindo caracteres não utilizados no idioma inglês, usando <a rel="mw:WikiLink" href="Codifica%C3%A7%C3%A3o" title="Codificação" id="mwEA">codificações</a> diferentes do ASCII, assim como formatos binários contendo <a rel="mw:WikiLink" href="Imagen" title="Imagen" class="mw-redirect" id="mwEQ">imagens</a>, <a rel="mw:WikiLink" href="Sons" title="Sons" class="mw-redirect" id="mwEg">sons</a>, <a rel="mw:WikiLink" href="Filme" title="Filme" id="mwEw">filmes</a>, e <a rel="mw:WikiLink" href="Programas_de_computador" title="Programas de computador" class="mw-redirect" id="mwFA">programas de computador</a>. MIME é também um componente fundamental de comunicação de protocolos como o <a rel="mw:WikiLink" href="HTTP" title="HTTP" id="mwFQ">HTTP</a>, que requer que os dados sejam transmitidos em contextos semelhantes a mensagens de email, mesmo que o dado a ser transmitido não seja realmente um e-mail.</p>

<p id="mwFg">O mapeamento de mensagens dentro e fora do formato MIME é tipicamente utilizado pelos clientes de email ou pelos servidores de email quando enviam ou recebem emails via SMTP/MIME.</p>

<p id="mwFw">O formato básico de <a rel="mw:WikiLink" href="E-mail" title="E-mail" id="mwGA">e-mail</a> é definido pela <a rel="mw:WikiLink" href="Request_for_Comments" title="Request for Comments" id="mwGQ">RFC</a> <a rel="mw:ExtLink nofollow" href="http://www.faqs.org/rfcs/rfc2822.html" class="external text" id="mwGg">2822</a>, que atualiza a versão <a href="https://datatracker.ietf.org/doc/html/rfc822" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwGw">RFC 822</a>.</p>

<p id="mwHA">Estes padrões especificam os formatos familiares para o <a rel="mw:WikiLink" href="Headers_de_e-mail" title="Headers de e-mail" class="mw-redirect" id="mwHQ">cabeçalho dos e-mails</a> e o corpo e as regras que pertencem aos campos geralmente usados do cabeçalho como "Para:", "Assunto:", "De:" e "Data:".</p>

<p id="mwHg">O MIME define uma coleção de cabeçalhos do e-mail para especificar atributos adicionais de uma mensagem incluindo o tipo de <a rel="mw:WikiLink" href="Caractere" title="Caractere" id="mwHw">caractere</a> do texto e dos arquivos (ficheiros) de transferência que podem ser usados para representar dados binários 8-bit usando caracteres de 7-bit ASCII. O MIME é extensivo, as suas definições incluem métodos para registrar novos conteúdos e valores.</p>

<p id="mwIA">Os objetivos da definição do MIME não eram mudanças aos usuários de e-mail. Este objetivo é conseguido permitindo que todos os atributos da mensagem do MIME sejam opcionais, com os valores padrões que fazem uma mensagem não-MIME, provavelmente, capaz de ser interpretada corretamente por um cliente MIME.</p>

</section><section data-mw-section-id="1" id="mwIg" aria-labelledby="Cabeçalhos_MIME"><div class="mw-heading mw-heading2"><h2 id="Cabeçalhos_MIME"><span id="Cabe.C3.A7alhos_MIME" typeof="mw:FallbackId"></span>Cabeçalhos MIME</h2></div>
<section data-mw-section-id="2" id="mwIw" aria-labelledby="Versão_MIME"><div class="mw-heading mw-heading3"><h3 id="Versão_MIME"><span id="Vers.C3.A3o_MIME" typeof="mw:FallbackId"></span>Versão MIME</h3></div>
<p id="mwJA">A presença deste cabeçalho indica que a mensagem tem o formato MIME. Tipicamente, o valor é "1.0"; portanto, este cabeçalho aparece como</p>
<pre id="mwJQ">  MIME-Version: 1.0</pre>

</section><section data-mw-section-id="3" id="mwJg" aria-labelledby="Tipos_de_conteúdos"><div class="mw-heading mw-heading3"><h3 id="Tipos_de_conteúdos"><span id="Tipos_de_conte.C3.BAdos" typeof="mw:FallbackId"></span>Tipos de conteúdos</h3></div>
<p id="mwJw">Tipos de conteúdo são identificados no cabeçalho da mensagem (<i id="mwKA">"header"</i>) como <i id="mwKQ">Content-Type</i>, que indica o <i id="mwKg">type</i> (tipo) e <i id="mwKw">subtype</i> (subtipo) do conteúdo da mensagem, p. ex.:</p>
<pre id="mwLA">  Content-type: text/plain</pre>

<p id="mwLQ">A combinação de tipo e subtipo é geralmente chamada <i id="mwLg">MIME type</i>, embora nas aplicações mais modernas o <i id="mwLw">Internet media type</i> seja o termo favorito, indicando a sua aplicação fora das mensagens MIME. Um grande número de formatos de ficheiro registrou o <i id="mwMA">MIME type</i>. Qualquer tipo de <i id="mwMQ">texto</i> tem um parâmetro <i id="mwMg">charset</i> que pode ser incluído para indicar a <a rel="mw:WikiLink" href="Codifica%C3%A7%C3%A3o_de_caracter" title="Codificação de caracter" class="mw-redirect" id="mwMw">codificação de caracter</a>. Uma grande quantidade de tipos de letra registraram nomes de <i id="mwNA">charset</i> MIME.</p>

<p id="mwNQ">Embora originalmente definido por MIME e-mail, o cabeçalho <i id="mwNg">conteúdo-tipo</i> e o tipo MIME de registro é reutilizado em outros protocolos de Internet, como <a rel="mw:WikiLink" href="HTTP" title="HTTP" id="mwNw">HTTP</a>. O tipo de registro MIME é administrado por <a rel="mw:WikiLink" href="Internet_Assigned_Numbers_Authority" title="Internet Assigned Numbers Authority" class="mw-redirect" id="mwOA">IANA</a>.</p>

<p id="mwOQ">Através do uso do tipo <i id="mwOg">multipart</i>, MIME permite mensagens com vários tipos de construções em <a rel="mw:WikiLink" href="%C3%81rvore_(estrutura_de_dados)" title="Árvore (estrutura de dados)" id="mwOw">árvore</a>, onde os <a rel="mw:WikiLink" href="N%C3%B3" title="Nó" id="mwPA">nós</a> da folha são qualquer tipo de mensagem <i id="mwPQ">multipart</i> e os nós não-folha são alguma variante do tipo multipart. Veja alguns mecanismos suportados:</p>

<ul id="mwPg"><li id="mwPw">Textos simples usando <i id="mwQA">text/plain</i> (este é o valor padrão para o "Content-type:")</li>
<li id="mwQQ">Texto com arquivos (ficheiros) anexos (<i id="mwQg">multipart/mixed</i> com uma parte <i id="mwQw">text/plain</i> e outra não-textual). Uma mensagem MIME incluindo um arquivo anexo geralmente é indicada o nome original do anexo no "Content-disposition:" dentro do <a rel="mw:WikiLink" href="Header" title="Header" class="mw-redirect" id="mwRA">cabeçalho</a>.</li>
<li id="mwRQ">Respostas com anexos originais (<i id="mwRg">multipart/mixed</i> com uma parte <i id="mwRw">text/plain</i> e a mensagem original como um MIME <i id="mwSA">message/rfc822</i>)</li>
<li id="mwSQ">Conteúdo alternativo, é usado quando uma mensagem é enviada em texto simples e, por exemplo, um cliente de email a transforma em <a rel="mw:WikiLink" href="HTML" title="HTML" id="mwSg">HTML</a> para o destino, o MIME será (<i id="mwSw">multipart/alternative</i> com o mesmo conteúdo do texto simples em <i id="mwTA">text/plain</i> mas o MIME transformado em <i id="mwTQ">text/html</i>)</li>
<li id="mwTg">Muitas outras construções de mensagens.</li></ul>

</section><section data-mw-section-id="4" id="mwTw" aria-labelledby="Codificação_de_conteúdo_de_transferência"><div class="mw-heading mw-heading3"><h3 id="Codificação_de_conteúdo_de_transferência"><span id="Codifica.C3.A7.C3.A3o_de_conte.C3.BAdo_de_transfer.C3.AAncia" typeof="mw:FallbackId"></span>Codificação de conteúdo de transferência</h3></div>
<p id="mwUA">Codificação de conteúdo de transferência são identificados como <i id="mwUQ">Content-Transfer-Encoding</i>. MIME (<a href="https://datatracker.ietf.org/doc/html/rfc2045" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwUg">RFC 2045</a>) define uma gama de métodos para a representação de dados binários em formato texto <a rel="mw:WikiLink" href="ASCII" title="ASCII" id="mwUw">ASCII</a>. O <i id="mwVA">content-transfer-encoding:</i> no header indica o método a ser utilizado. A <a rel="mw:WikiLink" href="Request_for_Comments" title="Request for Comments" id="mwVQ">RFC</a> e a <a rel="mw:ExtLink nofollow" href="http://www.iana.org/assignments/transfer-encodings" class="external text" id="mwVg">lista da IANA</a> são quem define os tipos de codificações de transferência:</p>

<ul id="mwVw"><li id="mwWA">Uso apropriado com SMTP normal:
<ul id="mwWQ"><li id="mwWg"><b id="mwWw">7bit</b> - acima de 998 octetos por linha na variação de [1..127] com CR e LF (códigos 10 e 13) reservado somente para aparecer como a parte de uma linha final de CRLF. Este é o valor padrão.</li>
<li id="mwXA"><b id="mwXQ">quoted-printable</b> - usado para textos simples com caracteres US-ASCII.</li>
<li id="mwXg"><b id="mwXw"><a rel="mw:WikiLink" href="Base64" title="Base64" id="mwYA">base64</a></b> - usado para dados binários arbitrários.</li></ul></li></ul>

<ul id="mwYQ"><li id="mwYg">Uso apropriado com servidores SMTP que suportam transporte 8BITMIME:
<ul id="mwZA"><li id="mwZQ"><b id="mwZg">8bit</b> - acima de 998 octetos por linha CR e LF (códigos de 10 e 13) reservado somente para aparecer como a parte de uma linha final de CRLF.</li></ul></li></ul>

<ul id="mwZw"><li id="mwaA">Não apropriado para uso com SMTP:
<ul id="mwaQ"><li id="mwag"><b id="mwaw">binário</b> - seqüência de octetos. Não usado com e-mails SMTP.</li></ul></li></ul>

<p id="mwbA">Não há nenhuma codificação definida que é projetada explicitamente para dados binários arbitrários com  transporte 8BITMIME, assim a <i id="mwbQ">base64</i> ou <i id="mwbg">quoted-printable</i> são às vezes ainda utilizados.</p>

</section></section><section data-mw-section-id="5" id="mwbw" aria-labelledby="Palavra_codificada"><div class="mw-heading mw-heading2"><h2 id="Palavra_codificada">Palavra codificada</h2></div>
<p id="mwcA">Desde a <a rel="mw:WikiLink" href="RFC" title="RFC" class="mw-redirect" id="mwcQ">RFC</a> 2822, os nomes e valores dos headers das mensagens são sempre caracteres <a rel="mw:WikiLink" href="ASCII" title="ASCII" id="mwcg">ASCII</a>. Valores que contenham caracteres não-ASCII são denominados <i id="mwcw">encoded-word</i> pelo MIME, ficando com a sintaxe da <a href="https://datatracker.ietf.org/doc/html/rfc2047" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwdA">RFC 2047</a> em vez da frase literal. Esta sintaxe usa a <a rel="mw:WikiLink" href="String" title="String" class="mw-redirect" id="mwdQ">string</a> de caracteres ASCII para indicar o tipo de codificação de caracter original, ou seja, o "<a rel="mw:WikiLink" href="Charset" title="Charset" class="mw-redirect" id="mwdg">charset</a>" e o "content-transfer-encoding" usado para o mapa de bytes do charset dentro dos caracteres ASCII.</p>

<p id="mwdw">A forma é: "<code id="mweA">=?</code><i id="mweQ">charset</i><code id="mweg">?</code><i id="mwew">encoding</i><code id="mwfA">?</code><i id="mwfQ">encoded text</i><code id="mwfg">?=</code>".</p>

<ul id="mwfw"><li id="mwgA">O <i id="mwgQ">charset</i> é frequentemente <a rel="mw:WikiLink" href="UTF-8" title="UTF-8" id="mwgg">utf-8</a>, mas pode ser qualquer caracter registrado com a <a rel="mw:WikiLink" href="Internet_Assigned_Numbers_Authority" title="Internet Assigned Numbers Authority" class="mw-redirect" id="mwgw">IANA</a>. iso-2022-jp é comum no <a rel="mw:WikiLink" href="Jap%C3%A3o" title="Japão" id="mwhQ">Japão</a>. <a rel="mw:WikiLink" href="ISO_8859" title="ISO 8859" class="mw-redirect" id="mwhg">iso-8859-1</a> e mais recentemente iso-8859-15 são comuns no leste <a rel="mw:WikiLink" href="Europa" title="Europa" id="mwiA">europeu</a>.</li>
<li id="mwiQ"><i id="mwig">encoding</i> pode ser um "<code id="mwiw">Q</code>" denotando a codificação da <i id="mwjA">quoted-printable</i> ou "<code id="mwjQ">B</code>" que denota a codificação <a rel="mw:WikiLink" href="Base64" title="Base64" id="mwjg">base64</a>.</li>
<li id="mwjw"><i id="mwkA">encoded text</i> (codificação do texto) é o texto da "quoted-printable" ou de "base64-encoded".</li></ul>

<p id="mwkQ">Por exemplo,</p>

<p id="mwkg"><code id="mwkw">Subject: =?utf-8?Q?=C2=A1Hola,=20se=C3=B1or!?=</code></p>

<p id="mwlA">é interpretado como "Subject: ¡Hola, señor!".</p>

<p id="mwlQ">O formato da <i id="mwlg">palavra codificada</i> ("encoded-word") não é usado nos nomes do <a rel="mw:WikiLink" href="Header" title="Header" class="mw-redirect" id="mwlw">cabeçalho</a>, somente no <code id="mwmA">Subject:</code> (Título). Todo o texto do cabeçalho é sempre escrito em <a rel="mw:WikiLink" href="L%C3%ADngua_inglesa" title="Língua inglesa" id="mwmQ">Inglês</a> . Quando a mensagem não está em inglês, o cabeçalho é traduzido pelo cliente de e-mail.</p>

</section><section data-mw-section-id="6" id="mwmg" aria-labelledby="Exemplo_de_Multipart"><div class="mw-heading mw-heading2"><h2 id="Exemplo_de_Multipart">Exemplo de Multipart</h2></div>
<p id="mwmw">Um MIME com mensagem multipart contém um "boundary" (literalmente, um "limite") no "Content-type:" do header; este boundary, é colocado entre as partes, no começo e no fim do corpo da mensagem, como segue:</p>

<dl id="mwnA"><dd id="mwnQ">
 Content-type: multipart/mixed; boundary="frontier"
 MIME-version: 1.0
--frontier
 Content-type: text/plain

 Este é o corpo da mensagem.

 --frontier
 Content-type: application/octet-stream
 Content-transfer-encoding: base64
 gajwO4+n2Fy4FV3V7zD9awd7uG8/TITP/vIocxXnnf/5mjgQjcipBUL1b3uyLwAVtBLOP4nV
 LdIAhSzlZnyLAF8na0n7g6OSeej7aqIl3NIXCfxDsPsY6NQjSvV77j4hWEjlF/aglS6ghfju
 FgRr+OX8QZMI1OmR4rUJUS7xgoknalqj3HJvaOpeb3CFlNI9VGZYz6H6zuQBOWZzNB8glwpC
--frontier--
</dd></dl>

</section><section data-mw-section-id="7" id="mwng" aria-labelledby="Referências"><div class="mw-heading mw-heading2"><h2 id="Referências"><span id="Refer.C3.AAncias" typeof="mw:FallbackId"></span>Referências</h2></div>
<ul id="mwnw"><li id="mwoA"><a href="https://datatracker.ietf.org/doc/html/rfc2045" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwoQ">RFC 2045</a> - Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message Bodies. N. Freed, Nathaniel Borenstein. November 1996. (Format: TXT=72932 bytes) (Obsoletes <a href="https://datatracker.ietf.org/doc/html/rfc1521" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwow">RFC 1521</a>, <a href="https://datatracker.ietf.org/doc/html/rfc1522" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwpA">RFC 1522</a>, <a href="https://datatracker.ietf.org/doc/html/rfc1590" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwpQ">RFC 1590</a>) (Updated by <a href="https://datatracker.ietf.org/doc/html/rfc2184" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwpg">RFC 2184</a>, <a href="https://datatracker.ietf.org/doc/html/rfc2231" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwpw">RFC 2231</a>)</li>
<li id="mwqA"><a href="https://datatracker.ietf.org/doc/html/rfc2046" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwqQ">RFC 2046</a> - Multipurpose Internet Mail Extensions (MIME) Part Two: Media Types. N. Freed, Nathaniel Borenstein. November 1996. (Format: TXT=105854 bytes) (Obsoletes <a href="https://datatracker.ietf.org/doc/html/rfc1521" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwqw">RFC 1521</a>, <a href="https://datatracker.ietf.org/doc/html/rfc1522" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwrA">RFC 1522</a>, <a href="https://datatracker.ietf.org/doc/html/rfc1590" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwrQ">RFC 1590</a>) (Updated by <a href="https://datatracker.ietf.org/doc/html/rfc2646" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwrg">RFC 2646</a>)</li>
<li id="mwrw"><a href="https://datatracker.ietf.org/doc/html/rfc2047" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwsA">RFC 2047</a> - MIME (Multipurpose Internet Mail Extensions) Part Three: Message Header Extensions for Non-ASCII Text. K. Moore. November 1996. (Format: TXT=33262 bytes) (Obsoletes <a href="https://datatracker.ietf.org/doc/html/rfc1521" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwsQ">RFC 1521</a>, <a href="https://datatracker.ietf.org/doc/html/rfc1522" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwsg">RFC 1522</a>, <a href="https://datatracker.ietf.org/doc/html/rfc1590" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwsw">RFC 1590</a>) (Updated by <a href="https://datatracker.ietf.org/doc/html/rfc2184" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwtA">RFC 2184</a>, <a href="https://datatracker.ietf.org/doc/html/rfc2231" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwtQ">RFC 2231</a>)</li>
<li id="mwtg"><a href="https://datatracker.ietf.org/doc/html/rfc2048" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwtw">RFC 2048</a> - Multipurpose Internet Mail Extensions (MIME) Part Four: Registration Procedures. N. Freed, J. Klensin, <a rel="mw:WikiLink" href="Jon_Postel" title="Jon Postel" id="mwuA">Jon Postel</a>. November 1996. (Format: TXT=45033 bytes) (Obsoletes <a href="https://datatracker.ietf.org/doc/html/rfc1521" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwuQ">RFC 1521</a>, <a href="https://datatracker.ietf.org/doc/html/rfc1522" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwug">RFC 1522</a>, <a href="https://datatracker.ietf.org/doc/html/rfc1590" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwuw">RFC 1590</a>) (Updated by <a href="https://datatracker.ietf.org/doc/html/rfc3023" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwvA">RFC 3023</a>) (Also BCP0013)</li>
<li id="mwvQ"><a href="https://datatracker.ietf.org/doc/html/rfc2049" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwvg">RFC 2049</a> - Multipurpose Internet Mail Extensions (MIME) Part Five: Conformance Criteria and Examples. N. Freed, N. Borenstein. November 1996. (Format: TXT=51207 bytes) (Obsoletes <a href="https://datatracker.ietf.org/doc/html/rfc1521" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwvw">RFC 1521</a>, <a href="https://datatracker.ietf.org/doc/html/rfc1522" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwwA">RFC 1522</a>, <a href="https://datatracker.ietf.org/doc/html/rfc1590" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwwQ">RFC 1590</a>)</li></ul>

</section><section data-mw-section-id="8" id="mwwg" aria-labelledby="Ligações_externas"><div class="mw-heading mw-heading2"><h2 id="Ligações_externas"><span id="Liga.C3.A7.C3.B5es_externas" typeof="mw:FallbackId"></span>Ligações externas</h2></div>
<ul id="mwww"><li id="mwxA"><a rel="mw:ExtLink nofollow" href="https://web.archive.org/web/20061004071705/http://db.org/" class="external text" id="mwxQ">Blog tracking Internet mail related drafts and standards</a></li>
<li id="mwxg"><a rel="mw:ExtLink nofollow" href="http://www.iana.org/assignments/media-types/" class="external text" id="mwxw">Lista de IANA registered MIME Media Types</a></li>
<li id="mwyA"><a rel="mw:ExtLink nofollow" href="http://www.iana.org/assignments/character-sets" class="external text" id="mwyQ">Lista de Conjunto de Caracteres</a></li>
<li id="mwyg"><a rel="mw:ExtLink nofollow" href="http://wiki.debian.org/MIME" class="external text" id="mwyw">MIME - Debian Wiki</a></li></ul>



</section></div><!--htdig_noindex--><div><div class="zim-footer">
    Este artigo é emitido por <a class="external text" title="Última edição em 2019-08-11" href="https://pt.wikipedia.org/wiki/?title=MIME&amp;oldid=55960134">Wikipédia</a>. O texto é licenciado sob <a class="external text" href="https://creativecommons.org/licenses/by-sa/4.0/deed.pt">Creative Commons Attribution-Share Alike 4.0</a>. Termos adicionais podem ser aplicados aos arquivos de mídia.
</div>
</div><!--/htdig_noindex--></div>
            </div>
          </main>
        </div>
      </div>
    </div>
     <script src="./_webp_/webpHandler.js"></script>
  

</body></html>