<!DOCTYPE html>
<html class="client-nojs vector-feature-language-in-header-enabled vector-feature-language-in-main-menu-disabled vector-feature-language-in-main-page-header-disabled vector-feature-page-tools-pinned-disabled vector-feature-toc-pinned-clientpref-0 vector-toc-not-available vector-feature-main-menu-pinned-disabled vector-feature-limited-width-clientpref-1 vector-feature-limited-width-content-enabled vector-feature-custom-font-size-clientpref-1 vector-feature-appearance-pinned-clientpref-0 skin-theme-clientpref-os vector-sticky-header-enabled skin-theme-clientpref-thumb-standard" lang="pt" dir="ltr"><head>
    <meta charset="UTF-8">
    <title>URI</title>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="icon" type="image/png" href="./_res_/favicon.png">
    <link rel="canonical" href="https://pt.wikipedia.org/wiki/URI"> <link href="./_mw_/ext.cite.parsoid.styles.css" rel="stylesheet" type="text/css">
    <link href="./_mw_/ext.cite.styles.css" rel="stylesheet" type="text/css">
    <link href="./_mw_/ext.wikimediamessages.styles.css" rel="stylesheet" type="text/css">
    <link href="./_mw_/mediawiki.skinning.content.parsoid.css" rel="stylesheet" type="text/css">
    <link href="./_mw_/skins.vector.icons.css" rel="stylesheet" type="text/css">
    <link href="./_mw_/skins.vector.search.codex.styles.css" rel="stylesheet" type="text/css">
    <link href="./_mw_/skins.vector.styles.css" rel="stylesheet" type="text/css">
    <meta name="ResourceLoaderDynamicStyles" content="">
    <link href="./_mw_/ext.gadget.keepPDU.css" rel="stylesheet" type="text/css">
    <link rel="stylesheet" type="text/css" href="./_mw_/site.styles.css">
    <link rel="stylesheet" type="text/css" href="./_mw_/noscript.css">
    <link rel="stylesheet" type="text/css" href="./_res_/footer.css">
    <link rel="stylesheet" type="text/css" href="./_res_/vector-2022.css">
  </head>
  <body class="skin--responsive skin-vector skin-vector-search-vue mediawiki ltr sitedir-ltr mw-hide-empty-elt ns-0 ns-subject page-URI rootpage-URI skin-vector-2022 action-view">
    <div class="mw-page-container">
      <div class="mw-page-container-inner">
        <div class="mw-content-container">
          <main id="content" class="mw-body">
            <header class="mw-body-header vector-page-titlebar">
              <h1 id="firstHeading" class="firstHeading mw-first-heading"><i>URI</i></h1>
            </header>
            <a id="top"></a>
            <div id="bodyContent" class="vector-body ve-init-mw-desktopArticleTarget-targetContainer" aria-labelledby="firstHeading" data-mw-ve-target-container="">
              <div id="contentSub">
                <div id="mw-content-subtitle"></div>
              </div>
              <div id="mw-content-text" class="mw-body-content mw-content-ltr" lang="pt" dir="ltr"><div class="mw-content-ltr mw-parser-output" lang="pt" dir="ltr" data-mw-parsoid-version="0.24.0.0-alpha2" data-mw-html-version="2.8.0"><section data-mw-section-id="0" id="mwAQ"><div class="hatnote" typeof="mw:Transclusion" id="mwAg"><span typeof="mw:File"><span><img src="./_assets_/0c70a452f799bfe840676ee341124611/Disambig_grey.svg.png" decoding="async" data-file-width="260" data-file-height="200" data-file-type="drawing" height="15" width="20" class="mw-file-element" loading="lazy"></span></span><span typeof="mw:Entity">&nbsp;</span><b>Nota:</b> Para a universidade, veja <a rel="mw:WikiLink" href="Universidade_Regional_Integrada_do_Alto_Uruguai_e_das_Miss%C3%B5es" title="Universidade Regional Integrada do Alto Uruguai e das Missões">Universidade Regional Integrada do Alto Uruguai e das Missões</a>.</div>
<p id="mwAw"><b id="mwBA">Uniform Resource Identifier</b> (URI)<sup class="mw-ref reference" id="cite_ref-1" rel="dc:references" typeof="mw:Extension/ref"><a href="#cite_note-1" id="mwBQ"><span class="mw-reflink-text" id="mwBg"><span class="cite-bracket" id="mwBw">[</span>1<span class="cite-bracket" id="mwCA">]</span></span></a></sup><sup class="mw-ref reference" id="cite_ref-2" rel="dc:references" typeof="mw:Extension/ref"><a href="#cite_note-2" id="mwCQ"><span class="mw-reflink-text" id="mwCg"><span class="cite-bracket" id="mwCw">[</span>2<span class="cite-bracket" id="mwDA">]</span></span></a></sup> é um termo técnico (e <a rel="mw:WikiLink" href="Anglicismo" title="Anglicismo" id="mwDQ">anglicismo</a> de <a rel="mw:WikiLink" href="Tecnologia_da_informa%C3%A7%C3%A3o" title="Tecnologia da informação" id="mwDg">tecnologia da informação</a>) que foi traduzido para a <a rel="mw:WikiLink" href="L%C3%ADngua_portuguesa" title="Língua portuguesa" id="mwDw">língua portuguesa</a> como um "identificador uniforme de recurso", é uma <a rel="mw:WikiLink" href="Cadeia_de_caracteres" title="Cadeia de caracteres" id="mwEA">cadeia de caracteres</a> compacta usada para <a rel="mw:WikiLink" href="Identificador" title="Identificador" id="mwEQ">identificar</a> ou denominar um recurso na <a rel="mw:WikiLink" href="Internet" title="Internet" id="mwEg">Internet</a>. O principal propósito desta identificação é permitir a interação com representações do recurso através de uma rede, tipicamente a <a rel="mw:WikiLink" href="World_Wide_Web" title="World Wide Web" id="mwEw">Rede Mundial</a>, usando <a rel="mw:WikiLink" href="Protocolo_(ci%C3%AAncia_da_computa%C3%A7%C3%A3o)" title="Protocolo (ciência da computação)" id="mwFA">protocolos</a> específicos. URIs são identificados em grupos definindo uma <a rel="mw:WikiLink" href="Sintaxe" title="Sintaxe" id="mwFQ">sintaxe</a> específica e protocolos associados.</p>

</section><section data-mw-section-id="1" id="mwFw" aria-labelledby="Relação_com_URL_e_URN"><div class="mw-heading mw-heading2"><h2 id="Relação_com_URL_e_URN"><span id="Rela.C3.A7.C3.A3o_com_URL_e_URN" typeof="mw:FallbackId"></span>Relação com URL e URN</h2></div>
<figure class="mw-halign-right" typeof="mw:File/Thumb" id="mwGA"><img src="./_assets_/0c70a452f799bfe840676ee341124611/URI_Venn_Diagram.svg.png" decoding="async" data-file-width="800" data-file-height="482" data-file-type="drawing" height="108" width="180" class="mw-file-element" id="mwGg" loading="lazy"><figcaption id="mwGw">Diagrama de conjuntos de grupos URI categorizados. Grupos na URL (locator) e URN (name) categorias são subconjuntos da URI, e, geralmente, também são <a rel="mw:WikiLink" href="Conjuntos_disjuntos" title="Conjuntos disjuntos" id="mwHQ">conjuntos disjuntos</a>.Tecnicamente URL e URN funcionam como IDs de recursos, no entanto, muitos conjuntos não podem ser categorizados como somente um ou outro, por que todos os URIs podem ser tratados como nomes, e alguns conjuntos integram aspectos de ambas, ou de nenhuma das categorias.</figcaption></figure>

<p id="mwHg">Um <b id="mwHw">URI</b> <i id="mwIA">pode</i> ser classificado como um localizador (URL) ou um nome (URN), ou ainda como ambos.</p>

<p id="mwIQ">Um <a rel="mw:WikiLink" href="URN" title="URN" id="mwIg">Nome de Recurso Uniforme</a> URN - Uniform Resource Name <span typeof="mw:Transclusion" id="mwIw">(em inglês)</span> é como o nome de uma pessoa, enquanto que um <a rel="mw:WikiLink" href="URL" title="URL" id="mwJA">Localizador de Recurso Uniforme</a> URL - Uniform Resource Locator <span typeof="mw:Transclusion" id="mwJQ">(em inglês)</span> é como o seu endereço. O URN define a identidade de um item, enquanto que o URL dá-nos um método para o encontrar.</p>

<p id="mwJg">Um URN típico é o sistema <a rel="mw:WikiLink" href="ISBN" title="ISBN" class="mw-redirect" id="mwJw">ISBN</a> para identificar individualmente os livros. ISBN 0-486-27557-4 (<span typeof="mw:Nowiki" id="mwKQ">urn:isbn:0-486-27557-4</span>) cita sem equívocos uma edição específica da obra de Shakespeare "Romeu e Julieta" - Romeo and Juliet <span typeof="mw:Transclusion" id="mwKg">(em inglês)</span>. Para aceder a este objeto e ler o livro, é necessário obter a sua localização, ou seja, através de um endereço URL. Um URL típico para este livro é um <a rel="mw:WikiLink" href="Caminho_(computa%C3%A7%C3%A3o)" title="Caminho (computação)" id="mwKw">caminho de arquivos</a>, como <code id="mwLA">file://home/pedro/Desktop/RomeoAndJuliet.pdf</code>, identificando o livro eletrónico salvo no <a rel="mw:WikiLink" href="Disco_r%C3%ADgido" title="Disco rígido" class="mw-redirect" id="mwLQ">disco</a> de um <a rel="mw:WikiLink" href="Computador_pessoal" title="Computador pessoal" id="mwLg">PC</a> local. Então o propósito de URNs e URLs é o de serem complementares.</p>

<section data-mw-section-id="2" id="mwLw" aria-labelledby="Aspectos_técnicos"><div class="mw-heading mw-heading3"><h3 id="Aspectos_técnicos"><span id="Aspectos_t.C3.A9cnicos" typeof="mw:FallbackId"></span>Aspectos técnicos</h3></div>
<p id="mwMA">Um URL é um URI que, além de identificar um recurso, provê meios de agir sobre obter e representar este recurso, descrevendo o seu mecanismo de acesso primário ou a localização na "rede". Por exemplo, o URL <i id="mwMQ"><span typeof="mw:Nowiki" id="mwMg">http://www.wikipedia.org/</span></i> é um URI que identifica um recurso (<a rel="mw:WikiLink" href="Wikipedia" title="Wikipedia" class="mw-redirect" id="mwMw">Wikipedia</a>) e implica a representação deste recurso (como o código <a rel="mw:WikiLink" href="HTML" title="HTML" id="mwNA">HTML</a> atual da página, como caracteres codificados está disponível via <a rel="mw:WikiLink" href="HTTP" title="HTTP" id="mwNQ">HTTP</a> de um hospedeiro de redes chamado www.wikipedia.org. Um <a rel="mw:WikiLink" href="URN" title="URN" id="mwNg">URN</a> é um URI que identifica um recurso pelo nome e um espaço de nome em particular. Um URN pode ser usado para falar sobre um recurso sem definir a sua localização ou como o aceder. Por exemplo, o URN <i id="mwNw"><span typeof="mw:Nowiki" id="mwOA">urn:isbn:0-395-36341-1</span></i> é um URI que especifica o sistema de identificação, em outras palavras, Número de Livro Padrão Internacional <a rel="mw:WikiLink" href="ISBN" title="ISBN" class="mw-redirect" id="mwOQ">ISBN</a> - International Standard Book Number <span typeof="mw:Transclusion" id="mwOg">(em inglês)</span>, como a única referência neste sistema e permite falar sobre o livro, mas não sugere onde ou como obter uma cópia real dele.</p>

<p id="mwOw">Em publicações técnicas, especialmente padrões produzidos pela <a rel="mw:WikiLink" href="IETF" title="IETF" class="mw-redirect" id="mwPA">IETF</a> e pelo <a rel="mw:WikiLink" href="W3C" title="W3C" id="mwPQ">W3C</a>, o termo <i id="mwPg">URL</i> tem sido <a rel="mw:WikiLink/Interwiki" href="https://en.wiktionary.org/wiki/depreciado" title="wiktionary:depreciado" class="extiw external" id="mwPw">depreciado</a>, já que raramente se torna necessária uma distinção entre URLs e URIs. Porém, fora de contextos técnicos e em software para a Rede Global, o termo <i id="mwQA">URL</i> permanece <a rel="mw:WikiLink/Interwiki" href="https://en.wiktionary.org/wiki/ubíquo" title="wiktionary:ubíquo" class="extiw external" id="mwQQ">ambíguo</a>. Além disso, o termo <i id="mwQg">endereço web</i>, que não possui qualquer definição formal, geralmente é usado em publicações não-técnicas como sinónimo para URL ou URI, embora geralmente se refira apenas a conjuntos URL "http" ou "https".</p>

</section><section data-mw-section-id="3" id="mwQw" aria-labelledby="RFC_3305"><div class="mw-heading mw-heading3"><h3 id="RFC_3305"><span typeof="mw:Nowiki" id="mwRA">RFC 3305</span></h3></div>
<p id="mwRQ">Muito desta discussão é tirado da RFC3305<sup class="mw-ref reference" id="cite_ref-3" rel="dc:references" typeof="mw:Extension/ref"><a href="#cite_note-3" id="mwRg"><span class="mw-reflink-text" id="mwRw"><span class="cite-bracket" id="mwSA">[</span>3<span class="cite-bracket" id="mwSQ">]</span></span></a></sup><span typeof="mw:Transclusion" id="mwSg">(em inglês)</span>, intitulada "Reportagem do planeamento da união W3C/IETF URI interessa grupo: Uniform Resource Identifiers (URIs), Uniform Resource Locator (URLs) e Uniform Resource Names (URNs): Explicações e Recomendações". Este RFC esboça o trabalho de um grupo de trabalho para união W3C/IETF que foi instalado especialmente para normalizar as visões divergentes levadas com o IETF e W3C, por meio das quais a relação foi entre os diversos termos e padrões "UR*". Enquanto não publicada uma padronização por ambas as organizações, tornou-se a base para um entendimento comum e tem informado muitos padrões.</p>

</section></section><section data-mw-section-id="4" id="mwSw" aria-labelledby="Sintaxe"><div class="mw-heading mw-heading2"><h2 id="Sintaxe">Sintaxe</h2></div>
<p id="mwTA">A sintaxe URI é essencialmente um nome de conjunto URI como "<a rel="mw:WikiLink" href="HTTP" title="HTTP" id="mwTQ">HTTP</a>", "<a rel="mw:WikiLink" href="FTP" title="FTP" class="mw-redirect" id="mwTg">FTP</a>", "<a rel="mw:WikiLink" href="Mailto" title="Mailto" class="mw-redirect" id="mwTw">mailto</a>", "<a rel="mw:WikiLink" href="URN" title="URN" id="mwUA">URN</a>", "tel", "rtsp", "file" etc, seguido de um caractere <a rel="mw:WikiLink" href="Dois_pontos" title="Dois pontos" class="mw-redirect" id="mwUg">dois pontos</a> e, por fim, a parte específica do conjunto. A sintaxe e a <a rel="mw:WikiLink" href="Sem%C3%A2ntica" title="Semântica" id="mwUw">semântica</a> desta parte específica é determinada pelas especificações que governam o conjunto, embora a sintaxe URI force todos os conjuntos a aderirem a uma síntese genérica que, além de outras coisas, reserva certos caracteres para propósitos especiais, mesmo sem dizer sempre quais esses propósitos são. A sintaxe URI também força restrições na parte específica do conjunto para, por exemplo, manter um certo grau de consistência quando a parte possui uma estrutura hierárquica. <i id="mwVA"><a rel="mw:WikiLink" href="Codifica%C3%A7%C3%A3o_URL" title="Codificação URL" class="mw-redirect" id="mwVQ">Codificação URL</a></i> geralmente é um aspecto mal-compreendido da sintaxe URI.</p>

<section data-mw-section-id="5" id="mwVg" aria-labelledby="Usos_de_referências_URI_em_linguagens_marcadores"><div class="mw-heading mw-heading3"><h3 id="Usos_de_referências_URI_em_linguagens_marcadores"><span id="Usos_de_refer.C3.AAncias_URI_em_linguagens_marcadores" typeof="mw:FallbackId"></span>Usos de referências URI em linguagens marcadores</h3></div>
<ul id="mwVw"><li id="mwWA">Em <a rel="mw:WikiLink" href="HTML" title="HTML" id="mwWQ">HTML</a>, o valor de <code id="mwWg">src</code>, atributo do elemento <code id="mwWw">img</code>, é uma referência URI, como também é o valor de <code id="mwXA">href</code> para os elementos <code id="mwXQ">a</code> ou <code id="mwXg">link</code>.</li>
<li id="mwXw">Em <a rel="mw:WikiLink" href="XML" title="XML" id="mwYA">XML</a>, o identificador de sistema sucedendo a palavra-chave <code id="mwYQ">SYSTEM</code> em um <a rel="mw:WikiLink" href="DTD" title="DTD" class="mw-redirect" id="mwYg">DTD</a> é uma referência URI sem fragmentos.</li>
<li id="mwYw">Em <a rel="mw:WikiLink" href="XSLT" title="XSLT" id="mwZA">XSLT</a>, o valor do atributo <code id="mwZQ">href</code> do elemento/instrução <code id="mwZg">xsl:import</code> é uma referência URI, como também o primeiro argumento da função <code id="mwZw">document()</code>.</li></ul>

</section><section data-mw-section-id="6" id="mwaA" aria-labelledby="Exemplos_de_URIs_Absolutas"><div class="mw-heading mw-heading3"><h3 id="Exemplos_de_URIs_Absolutas">Exemplos de URIs Absolutas</h3></div>
<ul id="mwaQ"><li id="mwag"><code id="mwaw"><a rel="mw:ExtLink nofollow" href="http://example.org/absolute/URI/with/absolute/path/to/resource.txt" class="external free" id="mwbA">http://example.org/absolute/URI/with/absolute/path/to/resource.txt</a></code></li>
<li id="mwbQ"><code id="mwbg"><a rel="mw:ExtLink nofollow" href="ftp://example.org/resource.txt" class="external free" id="mwbw">ftp://example.org/resource.txt</a></code></li>
<li id="mwcA"><code id="mwcQ">file://home/example/example.org/resource.txt</code></li>
<li id="mwcg"><code id="mwcw">urn:<a rel="mw:WikiLink" href="ISSN" title="ISSN" class="mw-redirect" id="mwdA">issn</a>:1535-3613</code></li></ul>

</section><section data-mw-section-id="7" id="mwdQ" aria-labelledby="Exemplos_de_referências_URI"><div class="mw-heading mw-heading3"><h3 id="Exemplos_de_referências_URI"><span id="Exemplos_de_refer.C3.AAncias_URI" typeof="mw:FallbackId"></span>Exemplos de referências URI</h3></div>
<ul id="mwdg"><li id="mwdw"><code id="mweA"><span typeof="mw:Nowiki" id="mweQ">http://pt.wikipedia.org/wiki/URI#Exemplos_de_referências_URI</span></code><span typeof="mw:Entity" id="mweg">&nbsp;</span>("<code id="mwew">http</code>" é o nome do 'conjunto', "<code id="mwfA">pt.wikipedia.org</code>" é a 'autoridade', "<code id="mwfQ">/wiki/URI</code>" é o 'caminho' apontando para este artigo, e "<code id="mwfg">#Exemplos_de_referências_URI</code>" é um 'fragmento' apontando para esta seção)</li>
<li id="mwfw"><span typeof="mw:Nowiki" id="mwgA">http://example.org/absolute/URI/with/absolute/path/to/resource.txt</span></li>
<li id="mwgQ">./relative/URI/with/absolute/path/to/resource.txt</li>
<li id="mwgg">relative/path/to/resource.txt</li>
<li id="mwgw">../../../resource.txt</li>
<li id="mwhA">../resource.txt#frag01</li>
<li id="mwhQ">resource.txt
<ol id="mwhg"><li id="mwhw">frag01</li></ol></li>
<li id="mwiA"><i id="mwiQ">(cadeia vazia)</i></li></ul>

</section></section><section data-mw-section-id="8" id="mwig" aria-labelledby="Ver_também"><div class="mw-heading mw-heading2"><h2 id="Ver_também"><span id="Ver_tamb.C3.A9m" typeof="mw:FallbackId"></span>Ver também</h2></div>
<ul id="mwiw"><li id="mwjA"><a rel="mw:WikiLink/Interwiki" href="https://en.wikipedia.org/wiki/en:Uniform%20Resource%20Identifier" title="w:en:Uniform Resource Identifier" class="extiw external" id="mwjQ">Uniform Resource Identifier (URI)</a> na Wikipédia <span typeof="mw:Transclusion" id="mwjg">(em inglês)</span></li>
<li id="mwjw"><a rel="mw:WikiLink" href=".arpa" title=".arpa" id="mwkA">.arpa</a>, uri.arpa é uma descoberta dinâmica</li>
<li id="mwkQ">História da internet</li>
<li id="mwkw"><a rel="mw:WikiLink" href="URL" title="URL" id="mwlA">URL</a> (Uniform Resource Locator)</li>
<li id="mwlQ"><a rel="mw:WikiLink" href="IRI" title="IRI" id="mwlg">IRI</a> (Internationalized Resource Identifier)</li>
<li id="mwlw"><a rel="mw:WikiLink" href="XRI" title="XRI" id="mwmA">XRI</a> (eXtensible Resource Identifier)</li>
<li id="mwmQ"><a rel="mw:WikiLink" href="IANA" title="IANA" class="mw-redirect" id="mwmg">IANA</a> (Internet Assigned Numbers Authority)</li>
<li id="mwmw"><a rel="mw:WikiLink" href="ICANN" title="ICANN" class="mw-redirect" id="mwnA">ICANN</a> (Internet Corporation for Assigned Names and Numbers)</li>
<li id="mwnQ"><a rel="mw:WikiLink" href="W3C" title="W3C" id="mwng">W3C</a> (World Wide Web Consortium)</li>
<li id="mwnw"><a rel="mw:WikiLink" href="Codifica%C3%A7%C3%A3o_URL" title="Codificação URL" class="mw-redirect" id="mwoA">Codificação URL</a></li>
<li id="mwoQ"><a rel="mw:WikiLink" href="URN" title="URN" id="mwog">URN</a></li>
<li id="mwow"><a rel="mw:WikiLink" href="Website" title="Website" class="mw-redirect" id="mwpA">Website</a></li></ul>

</section><section data-mw-section-id="-1" id="mwpQ" aria-labelledby="Referências"><div class="mw-heading mw-heading2"><h2 typeof="mw:Transclusion" id="Referências"><span id="Refer.C3.AAncias" typeof="mw:FallbackId"></span><span style="cursor: help;" title="Esta seção foi configurada para não ser editável diretamente. Edite a página toda ou a seção anterior em vez disso.">Referências</span></h2></div><span>

</span><div class="reflist" style=" list-style-type: decimal;" id="mwpg"><div class="mw-references-wrap" typeof="mw:Extension/references" id="mwpw"><ol class="mw-references references" id="mwqA"><li id="cite_note-1" data-mw-footnote-number="1"><span class="mw-cite-backlink" id="mwqQ"><a href="#cite_ref-1" rel="mw:referencedBy" id="mwqg"><span class="mw-linkback-text" id="mwqw">↑</span></a></span> <span id="mw-reference-text-cite_note-1" class="mw-reference-text reference-text"><a rel="mw:ExtLink nofollow" href="https://www.w3.org/Addressing/URL/uri-spec.html" class="external text" id="mwrA">Universal Resource Identifier (URI) (W3C)</a></span></li>
<li id="cite_note-2" data-mw-footnote-number="2"><span class="mw-cite-backlink" id="mwrQ"><a href="#cite_ref-2" rel="mw:referencedBy" id="mwrg"><span class="mw-linkback-text" id="mwrw">↑</span></a></span> <span id="mw-reference-text-cite_note-2" class="mw-reference-text reference-text"><a rel="mw:ExtLink nofollow" href="https://developer.mozilla.org/pt-BR/docs/Glossario/URI" class="external text" id="mwsA">Universal Resource Identifier (URI) (Developer Mozilla)</a></span></li>
<li id="cite_note-3" data-mw-footnote-number="3"><span class="mw-cite-backlink" id="mwsQ"><a href="#cite_ref-3" rel="mw:referencedBy" id="mwsg"><span class="mw-linkback-text" id="mwsw">↑</span></a></span> <span id="mw-reference-text-cite_note-3" class="mw-reference-text reference-text"><a rel="mw:ExtLink nofollow" href="http://rfc-editor.org/cgi-bin/rfcdoctype.pl?loc=RFC&amp;letsgo=3305&amp;type=http&amp;file_format=txt" typeof="mw:Transclusion" class="external text" id="mwtA">RFC3305</a><span typeof="mw:Entity" id="mwtQ"> </span><span id="mwtg">(em</span><span typeof="mw:Nowiki" id="mwtw"> </span><a rel="mw:WikiLink" href="L%C3%ADngua_inglesa" title="Língua inglesa" id="mwuA">inglês</a><span id="mwuQ">)., acessado pela última vez há 908 </span><a rel="mw:WikiLink" href="Semana" title="Semana" id="mwug">semanas</a></span></li>
</ol></div></div>

</section><section data-mw-section-id="9" id="mwuw" aria-labelledby="Ligações_externas"><div class="mw-heading mw-heading2"><h2 id="Ligações_externas"><span id="Liga.C3.A7.C3.B5es_externas" typeof="mw:FallbackId"></span>Ligações externas</h2></div>
<ul id="mwvA"><li id="mwvQ"><a href="https://datatracker.ietf.org/doc/html/rfc3986" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwvg">RFC 3986</a> / STD 66 (2005) – a atual especificação genérica de sintaxe para URI</li>
<li id="mwvw"><a href="https://datatracker.ietf.org/doc/html/rfc2396" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwwA">RFC 2396</a> (1998) and <a href="https://datatracker.ietf.org/doc/html/rfc2732" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwwQ">RFC 2732</a> (1999) – versão da especificação genérica de sintaxe para URI, obsoleta mas amplamente implementada</li>
<li id="mwwg"><a href="https://datatracker.ietf.org/doc/html/rfc1808" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwww">RFC 1808</a> (1995) – companheira obsoleta da <span typeof="mw:Nowiki" id="mwxA">RFC 1738</span> cobrindo processamentos relativos de URL</li>
<li id="mwxQ"><a href="https://datatracker.ietf.org/doc/html/rfc1738" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwxg">RFC 1738</a> (1994) – maior parte obsoleta da definição de conjuntos <a rel="mw:WikiLink" href="URL" title="URL" id="mwxw">URL</a> e sintaxe genérica URI</li>
<li id="mwyA"><a href="https://datatracker.ietf.org/doc/html/rfc1630" rel="mw:ExtLink nofollow" class="external mw-magiclink mw-magiclink-rfc" id="mwyQ">RFC 1630</a> (1994) – a primeira especificação genérica de sintaxe para URI; primeiro conhecimento de URLs em um padrão para Internet</li>
<li id="mwyg"><a rel="mw:ExtLink nofollow" href="http://www.iana.org/assignments/uri-schemes.html" class="external text" id="mwyw">URI Schemes</a>– Registro mantido pela <a rel="mw:WikiLink" href="IANA" title="IANA" class="mw-redirect" id="mwzA">IANA</a> de conjuntos URI</li>
<li id="mwzQ"><a rel="mw:ExtLink nofollow" href="https://web.archive.org/web/20050730073732/http://gbiv.com/protocols/uri/" class="external text" id="mwzg">URI Working Group</a>– centro de coordenação de desenvolvimento de padrões URI</li>
<li id="mwzw"><a rel="mw:ExtLink nofollow" href="http://www.w3.org/TR/webarch/#identification" class="external text" id="mw0A">Architecture of the World Wide Web, Volume One, §2: Identification</a>– pelo W3C</li>
<li id="mw0Q"><a rel="mw:ExtLink nofollow" href="http://norman.walsh.name/2006/07/25/namesAndAddresses" class="external text" id="mw0g">Exemplo de discussão sobre nomes e endereços</a></li>
<!--* [http://dm93.org/2005/05uuu/uuu.html Identifying, locating, and naming things on the Web] – Pelo D.Connolly (Ironicamente este link retorna um erro de "Resource not found") -->
<li id="mw0w"><a rel="mw:ExtLink nofollow" href="http://www.w3.org/Addressing/" class="external text" id="mw1A">Materiais do W3C relacionados a Endereçamento</a></li>
<li id="mw1Q"><a rel="mw:ExtLink nofollow" href="http://www.w3.org/TR/uri-clarification/" class="external text" id="mw1g">Explicação da W3C sobre URI</a></li>
<li id="mw1w"><a rel="mw:ExtLink nofollow" href="http://uriencode.com/" class="external text" id="mw2A">Codificador/decodificador URL Online (baseado em javascript)</a></li>
<li id="mw2Q"><a rel="mw:ExtLink nofollow" href="http://www.ltg.ed.ac.uk/~ht/WhatAreURIs/" class="external text" id="mw2g">What's a URI and why does it matter?</a>(2008) - pelo W3C</li>
<li id="mw2w"><a rel="mw:ExtLink nofollow" href="http://www.w3.org/2001/tag/doc/selfDescribingDocuments-2008-12-03.html" class="external text" id="mw3A">The Self-Describing Web</a>(2008) - do W3C</li></ul>
<div role="navigation" class="navbox" aria-labelledby="Controle_de_autoridade" style="padding:3px" typeof="mw:Transclusion" id="mw3Q"><table class="nowraplinks hlist navbox-inner" style="border-spacing:0;background:transparent;color:inherit"><tbody><tr><th id="Controle_de_autoridade" scope="row" class="navbox-group" style="width:1%;width: 12%; text-align:center;">Controle de autoridade</th><td class="navbox-list navbox-odd " style="text-align:left;border-left-width:2px;border-left-style:solid;width:100%;padding:0px"><div style="padding:0em 0.25em">
<ul><li><span style="white-space:nowrap;"><span typeof="mw:File"><img alt="Wd" src="./_assets_/0c70a452f799bfe840676ee341124611/Wikidata-logo.svg.png" decoding="async" data-file-width="1050" data-file-height="590" data-file-type="drawing" height="11" width="20" class="mw-file-element" loading="lazy"></span>: <span class="uid"><a rel="mw:WikiLink/Interwiki" href="https://www.wikidata.org/wiki/Q61694" title="wikidata:Q61694" class="extiw external">Q61694</a></span></span></li>
<li><span style="white-space:nowrap;"><a rel="mw:WikiLink" href="N%C3%BAmero_de_controle_da_Biblioteca_do_Congresso" title="Número de controle da Biblioteca do Congresso">LCCN</a>: <span class="uid"><span class=""><a rel="mw:ExtLink nofollow" href="https://id.loc.gov/authorities/sh2002000192" class="external text">sh2002000192</a></span></span></span></li></ul>

</div></td></tr></tbody></table></div>

<div style="display: none;" typeof="mw:Transclusion" id="mw3w"></div>




</section></div><!--htdig_noindex--><div><div class="zim-footer">
    Este artigo é emitido por <a class="external text" title="Última edição em 2024-02-16" href="https://pt.wikipedia.org/wiki/?title=URI&amp;oldid=67490716">Wikipédia</a>. O texto é licenciado sob <a class="external text" href="https://creativecommons.org/licenses/by-sa/4.0/deed.pt">Creative Commons Attribution-Share Alike 4.0</a>. Termos adicionais podem ser aplicados aos arquivos de mídia.
</div>
</div><!--/htdig_noindex--></div>
            </div>
          </main>
        </div>
      </div>
    </div>
     <script src="./_webp_/webpHandler.js"></script>
  

</body></html>